Installer doesn't recognize CD

Need help with one of the installers?
Post Reply

Installer doesn't recognize CD

Post by rottenart » Wed Apr 21, 2010 1:57

Hi all. I'm trying to install SC3U on ubuntu 9.10. the Loki Installer starts fine but when I put the CD in the drive, it is not recognized. I tried all my roms, but every time, the installer pops up: "please insert the cd into the drive"

I wonder if it is because it is a burned copy and the Cd itself is not titled "Sim City 3000 Unlimited Loki"? Is there a way to get the installer to recognize a mounted iso instead? Thanks...


Post by rottenart » Wed Apr 21, 2010 3:18

I tried burning a new iso with the right title, but evidently, the iso architecture doesn't like "Sim City 3000 Unlimited Loki Disc" as a title because it just read as blank when I inserted it into the drive. I am completely at a loss here, which sucks. I have spent 6 hrs trying to get this game to work. It really shouldn't be this difficult. Anyone have any ideas? Help?

liflg member
Posts: 218
Joined: Mon Mar 27, 2006 2:07
Location: CH

Post by rettichschnidi » Wed Apr 21, 2010 12:51

I guess you are trying to use a windowsversion of SC3U - that will not work, you need the linuxversion of this game.

You can buy it i.e. here: ... 000US.html

Posts: 1
Joined: Thu Dec 30, 2010 14:12

Post by theadamdy » Thu Dec 30, 2010 14:14

exactly the same problem here... and no, ist sn't a windowsversion...

liflg member
Posts: 1668
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Thu Dec 30, 2010 17:21

Hi theadamdy,

what installer exactly did you use?
Please send "ls -Rl" of your Sim City 3000 Unlimited Loki disc to team at liflg dot org.


Post Reply