How am I supposed to install UT GOTY with 2 CD's?

Need help with one of the installers?

How am I supposed to install UT GOTY with 2 CD's?

Post by cabriofahrer » Wed Oct 27, 2010 15:06

I own the 2 old original CD's of UT GOTY and I wanted to install the game using the goty installer of this site but it doesn't work.
I have FreeBSD8.1 (x86) with gnome 2.30 installed and HAL working properly. But I think that doesn't matter, on Linux the problem would be the same.
I know that in order for the installer to find the CD, you have to do a

'senenv SETUP_CDROM /pathtoCD',

so I tried

'setenv SETUP_CDROM /media/UT_GOTY_CD1',

which is what appears mounted in /media automatically by HAL.
Then I start the installer with


This works fine for the first CD, the installer works and installs the contents of CD1, until it prompts me to insert CD2. But when I unmount CD1 with nautilus, insert CD2 and wait for it to mount and finally press "OK" on the installer, it doesn't find CD2, leaving me with no other choice than terminating the installation.
Of course when inserting CD2 it appears mounted as "/media/UT_GOTY_CD2", so I thougt that would be the problem.

But when I start all over again from the beginning with

'setenv SETUP_CDROM /media/UT_GOTY_CD*'


'setenv SETUP_CDROM /media/UT_GOTY*'

hoping that then I overcome the difference in the name of the mounted location, it still doesn't work. The installer when prompting for the second CD, doesn't find it after unmounting CD1 and mounting CD2.

Then I tried a

'setenv SETUP_CDROM /mnt'
'mount -t cd9660 /dev/acd0 /mnt'

to see what happens then. And this is very odd: This time the installer seems to detect CD1, but without installing any content of it like before, prompts immediately to insert CD2!
So when in another terminal (how else, because the original terminal is used by the installer an it is still open, prompting to insert CD2) I

do a

'umount /mnt'
'mount -t cd9660 /dev/acd0 /mnt'

CD2 is mounted, and I press "OK" on the installer, it installs a few files from CD2, reports a "successful" installation and I can push on the "exit" button. But of course, the installation was not successful, because the contents of CD1 were not installed before promting to insert CD2!
My impression after this really is, that the installer only works when the two CD's are mounted in one location at the same time, but how would do that when I don't have 2 CD drives?
Why does

'setenv SETUP_CDROM /media/UT_GOTY*' (or /media/UT_GOTY_CD*)

not work for CD2, when it had worked for CD1 just a moment before?
Am I missing something or does the installer not really work?
Also, why do I need CD2 anyway, when I first chose a "base install" and not "S3TC textures"?

In windows CD1 achieves a complete installation of the game, you can later use CD2 for an additional installation of S3TC textures. That also leads me to believe that there is something wrong with the linux installer.

liflg member
Posts: 1668
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Thu Oct 28, 2010 19:06

Hi cabriofahrer,

please send a list (ls -lRa) of the file/directory structure of your discs to


Based on your nick, I assume you are German?
If so, you can write your email in German :D

liflg member
Posts: 1668
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Tue Nov 02, 2010 10:06

Hi cabriofahrer,

did you get my e-mail?

liflg member
Posts: 1668
Joined: Fri Oct 22, 2004 16:23

Post by kratz00 » Wed Nov 24, 2010 21:28

This problem is solved now, cabriofahrer and I talked via email.

This is what he did before running the installer:

Code: Select all

ln -s /media/UT_GOTY_CD1 /home/cabriofahrer/ut
ln -s /media/UT_GOTY_CD2 /home/cabriofahrer/ut
setenv SETUP_CDROM_DISC1 /home/cabriofahrer/ut/UT_GOTY_CD1
setenv SETUP_CDROM_DISC2 /home/cabriofahrer/ut/UT_GOTY_CD2
The mount points are created by the HAL daemon.
After the installation he had to create some soft links in /compat/linux/usr/local/lib because of FreeBSD.